Yast Linux

YaST es una herramienta de configuración del estilo del panel de configuración de Windows 9x. Se usa siempre en la instalación de una distribución SuSE Linux, pero podemos volver sobre ella para cambiar cualquier parámetro introducido, como el idioma, la distribución del teclado, el ratón, etc. Además dispone de una serie de herramientas para instalar hardware, configurar redes, etc.

Se invoca en cualquier momento desde un shell con el comando YaST.

El menú principal de opciones es el siguiente:

 

YAST Nro 1

Como se puede ver, está en español. La ayuda general es extremadamente útil en caso de duda, con enlaces on-line desde el mismo texto.

Ajustes de la instalación:

Desde los ajustes de la instalación podemos ajustar configuraciones básicas de la instalación, como son el idioma, teclado, etc. Estas opciones son:

Yast 2

De estas opciones las más importantes son la cuarta y la quinta. Veremos una descripción más completa a continuación.

4.-Configurar las particiones:


Primero nos preguntará si queremos particionar o usar todo el espacio disponible en el disco. Escogemos la primera opción, con lo que aparece la pantalla de edición de la tabla de partición:

000065582

Cada línea representa una partición del sistema, que puede estar montada o no. Si tenemos espacio libre podemos añadir particiones pulsando F5. Entonces nos pedirá la longitud en cilindros de disco de la partición a añadir. Si esto resulta incómodo, se puede introducir un número seguido de MB, y el programa calculará automáticamente el número de cilindros. En la figura aparecen los cinco tipos de particiones más comunes: MS-DOS, Linux, Partición de intercambio de Linux( Swap), Extendida(Esta partición es lógica, no física), y FAT32. Por supuesto, puede haber otros tipos, pero no son tan usados.

5.- Establecer las particiones destino:

Este menú sirve para hacer que el sistema linux reconozca y monte automáticamente al arrancar las particiones que tiene el disco duro. Un posible ejemplo es el siguiente:

000065583

Como en el anterior menú, cada línea representa una partición, pero en este caso la información presentada de cada una de ellas es diferente. Además del tipo de partición lo que nos interesa en este caso es el “punto de anclaje”( Está mal traducido: Sería el punto de montaje), que no es más que el directorio desde el que se accederá a la partición. Es importante que al menos exista una partición raíz en el sistema de archivos, que estará montada en “/”. Además, vemos que aparecen unas líneas más en color blanco. Estas líneas representan la información de las particiones que, o bien no están montadas, como el CD-ROM o la disquetera, o bien son particiones que usa el sistema por sí mismo, como el espacio de intercambio(Swap), o el directorio /proc. Otra cosa importante a tener en cuenta es la posibilidad de formateo de las particiones seleccionadas para ello. Esto se puede ver en el campo “Formato” de la tabla.

Escoger/Instalar paquetes:

Es posible que esta sea la opción más importante de YaST ,o al menos sí la más usada.

Se despliega el submenú siguiente:

000065584

Cargar configuración: Nos da a elegir entre varias combinaciones de paquetes de instalación. Pulsando F2 nos indica la lista de paquetes que se instalan.

000065585

Salvar configuración: Si escogemos una combinación de paquetes y la modificamos, con esta opción se pueden grabar los cambios para futuras instalaciones.

Cambiar/Crear configuración: Nos deja la posibilidad de escoger los paquetes que queramos y los que no. Es recomendable partir de una configuración básica para luego ir añadiendo paquetes.

Comprobar las dependencias: Algunos paquetes requieren de la previa instalación de otros, como librerías, el entorno gráfico, etc. Esta opción comprueba estas dependencias, pero al instalar los paquetes el programa hará esto automáticamente por nosotros.

Información de paquetes: Si queremos una breve descripción de cada paquete, además de los archivos que lo componen, en esta opción lo encontramos:

000065586

Empezar instalación: Una vez seleccionada una combinación de paquetes con esta opción comenzará la instalación de los mismos. Antes de comenzar la instalación hará una comprobación de las dependencias de los mismos. Algunos paquetes no contienen una especificación de éstas. YaST nos advertirá de este incidente.

Instalar paquetes: Si lo que queremos es instalar paquetes RPM externos a la distribución, con esta opción podremos hacerlo. Se pueden instalar vía CD-Rom, desde internet, desde un disquete, o desde un directorio del disco duro. Si lo hacemos desde el CD-Rom, que es lo más normal, éste se montará automáticamente en el directorio /var/adm/mount , así que habrá que navegar por el sistema de archivos para buscar los paquetes:

000065587

Eliminar paquetes: Esta opción permite la desinstalación de los paquetes que constituyan parte de la distribución, esto es, el primer CD-Rom. Nos ofrece una larga lista de paquetes. Se seleccion los que se quieran eliminar, y se pulsa F10 para proceder a su eliminación.

Administración del sistema: 

Para la instalación y mantenimiento de hardware, redes, etc tenemos las siguientes opciones:

000065588

Instalar hardware en el sistema: Permite la configuración del hardware del sistema; Ratón, módem, CD-Rom, etc.

000065589

Kernel y configurar arranque: Instala un kernel predeterminado en el arranque del disco duro. No da muchos para elegir, sólo unos cuantos, variando principalmente el controlador del medio de arranque( SCSI, IDE, etc.), soporte de red, etc.

Configuración de red: Permite describir la configuración de red a partir de una dirección IP. máscara de red, etc. Despliega un submenú:

0000655810

Crear Buckups:  Hace una copia de seguridad de los archivos especificados. Se pueden quitar sistemas

de archivos enteros( Como pueda ser uno Windows), seleccionar directorios, etc.

0000655812

Conclusión:

El YaST es una potente herramienta que nos ahorra el tener que editar múltiples archivos de configuración, y dar muchas vueltas con cosas que pudieran parecer en principio triviales, como la instalación de un ratón. Este programa busca cada posible uso que se le pueda dar a cada opción, y configura el sistema por nosotros. Por ello, cada vez que introduzcamos un cambio con esta herramienta, se lanzará el “SuSEConfig” y hará los cambios necesarios en el sistema para que los cambios introducidos se hagan efectivos.

Guardar Configuración Cisco

Para guardar la configuración primero accedemos al equipo a través de telnet o por el puerto serial. Ya dentro uno debe entrar en modo super usuario, para eso desde la línea de comando uno escribe “enable”, ahí nos pide la clave de configuración. El prompt cambia de router> a router#, para ver la configuración actual siendo usada uno puede escribir directamente “show running-config”, esa es toda la configuración activa del equipo, normalmente son una o varias pantallas dependiendo de la configuración. La configuración de un cisco puede ser guardada en modo texto así que un copy & paste de esa configuración ya te sirve.
Una forma más elegante es si tienes un servidor de tftp insalado en alguna maquina de tú red (se puede bajar uno gratuito para windows/windows nt/linux), es escribiendo desde el modo superusiario “copy startup-config tftp”

Sobre la configuración VLAN, G-703 y DXX depende mucho de que equipos tengas de por medio, hay que tener en cuenta los tipos de interfaces de por medio. Ojo que un 2514 tiene puertos seriales sincronos y dos puertos LAN o sea que requiere un conversor de interface si se van a utilizar interfaces que no correspondan a este tipo de interface.

Por cualquier cosa estoy a disposición, y si me pasás más detalles sobre las interconexiones y sub-redes te puedo ayudar en tus pruebas.

Atentamente,

VHMC

Tomado de :

http://www.todoexpertos.com/categorias/ciencias-e-ingenieria/ingenieria-telecomunicaciones/respuestas/52345/configuracion-cisco

Posted in Cisco. Tags: , , . No Comments »

Ejemplo de Configuracion NAT Dinamico en Routers Cisco

logo_ciscoEl NAT dinamico está diseñado para mapear una dirección IP privada a una dirección pública de entre un pool de direcciones públicas ya establecido. Es decir, Cualquier dirección IP pública de este pool se asigna a un host de la red interna.

1) Primero definir un pool de direcciones (las direcciones públicas que nos asigne nuestro ISP)
Router-Cisco#configure treminal
Router-Cisco(config)# ip nat pool 1 200.42.1.1 200.42.1.10 netmask 255.255.255.0

2) Crear una lista de acceso estándard que permita las direcciones internas que se deben traducir.
Router-Cisco(config)# access-list 1 permit 172.16.129.0 0 0.0.0.255

3) Configurar la NAT dinamico basada en la dirección de origen especificando la lista de acceso definida en el paso anterior.
Router-Cisco(config)# ip nat inside source list 1 pool 1

4) Especificar la interfaz interna y marcarla como conectada al interior.
Router-Cisco(config)# interface etherne 0
Router-Cisco(config-if)# ip nat inside
Router-Cisco(config-if)# exit

5) Especificar la interfaz externa y marcarla como conectada al exterior.
Router-Cisco(config)# interface serial 0
Router-Cisco(config)# ip nat outside

Comandos para verificación de la tabla NAT

show ip nat translations
show ip nat statistics
debug ip nat

Instalación y Configuración de Servidor Samba

Saludos ante tantas consultas acerca de este tema, y ya que en varias empresas necesitan aqui les dejo unos videos en youtube que me sirvieron mucho cuando empece. Mirenlos en HD se los recomiendo ;) .

Configuración de Cisco Básica

Configurar un router, al principio, parece una tarea complicada. Con el paso del tiempo, aprendiendo los comandos, sus funciones y configurando, nos vamos a dar cuenta que no lo es para nada, todo lo contrario, termina siendo un proceso simple, mecánico.

Este tutorial solo contiene la configuración básica de un router, la que deberemos realizar siempre, sin importar que protocolos de enrutamiento o servicios configuremos después. Comencemos.

Los routers tienen varios Modos y Submodos de configuración:

Modo Exec Usuario: Este modo solo permite ver información limitada de la configuración del router y no permite modificación alguna de ésta.

Modo Exec Privilegiado: Este modo permite ver en detalle la configuración del router para hacer diagnósticos y pruebas. También permite trabajar con los archivos de configuración del router (Flash – NVRAM).

Modo de Configuración Global: Este modo permite la configuración básica de router y permite el acceso a submodos de configuración especéficos.
Cambio entre modos
router>
router> enable (pasa al Modo Exec Privilegiado)
router#
router# exit (vuelve a al Modo Exec Usuario)
router> enable
router#
router# config terminal (pasa al Modo Configuración Global)
router(config)#
router(config)# exit ó CTRL+z (vuelve al Modo Exec Privilegiado)
router#

Nombrar al router
router> enable
router# configure terminal
router(config)# hostname RouterA (nombra al router como)
RouterA(config)#

Configurar contraseñas “enable secret” y “enable password”
RouterA> enable
RouterA# configure terminal
RouterA(config)# enable secret contraseña (configura contraseña Enable Secret)
RouterA(config)# enable password contraseña * (configura contraseña Enable Password)
RouterA(config)#

* Es recomendable configurar Enable Password ya que genera una clave global cifrada en el router.

Configurar contraseña de consola
RouterA> enable
RouterA# config terminal
RouterA(config)# line con 0 (ingresa a la Consola)
RouterA(config-line)# password contraseña (configura contraseña)
RouterA(config-line)# login (habilita la contraseña)
RouterA(config-line)# exit
RouterA(config)#

Configurar contraseña vty (telnet)
RouterA> enable
RouterA# config terminal
RouterA(config)# line vty 0 4 (crea las 5 líneas VTY, pero podría ser una sola. Ej: line vty 0)
RouterA(config-line)# password contraseña (contraseña para las 5 líneas en este caso)
RouterA(config-line)# login (habilita la contraseña)
RouterA(config-line)# exit
RouterA(config)#

Configurar interfaces ethernet o fast ethernet
RouterA> enable
RouterA# config terminal
RouterA(config)# interface fastethernet 0/0 * (ingresa al Submodo de Configuración de Interfaz)
RouterA(config-if)# ip address 192.168.0.1 255.255.255.0 (configura la IP en la interfaz)
RouterA(config-if)# no shutdown (levanta la interfaz)
RouterA(config-if)# description lan (asigna un nombre a la interfaz)
RouterA(config-if)# exit
RouterA(config)#

* Tener en cuenta que la interfaz puede ser Ethernet o Fast Ethernet y que el número de interfaz puede ser 0, 1, 0/0, 0/1, etc. Esto varía según el router.

Configurar interfaces serial como dte
RouterA> enable
RouterA# config terminal
RouterA(config)# interface serial 0/0 * (ingresa al Submodo de Configuración de Interfaz)
RouterA(config-if)# ip address 10.0.0.1 255.0.0.0 (configura la IP en la interfaz)
RouterA(config-if)# no shutdown (levanta la interfaz)
RouterA(config-if)# description red (asigna un nombre a la interfaz)
RouterA(config-if)# exit
RouterA(config)#

* Tener en cuenta que el número de interfaz puede ser 0, 1, 0/0, 0/1, etc. Esto varía según el router.

Configurar interfaces serial como dce
RouterB> enable
RouterB# config terminal
RouterB(config)# interface serial 0/1 * (ingresa al Submodo de Configuración de Interfaz)
RouterB(config-if)# ip address 10.0.0.2 255.0.0.0 (configura la IP en la interfaz)
RouterB(config-if)# clock rate 56000 (configura la sincronización entre los enlaces)
RouterB(config-if)# no shutdown (levanta la interfaz)
RouterB(config-if)# description red (asigna un nombre a la interfaz)
RouterB(config-if)# exit
RouterB(config)#

* Tener en cuenta que el número de interfaz puede ser 0, 1, 0/0, 0/1, etc. Esto varía según el router.

Fuente: www.garciagaston.com.ar

Posted in Cisco. Tags: , , . No Comments »

Configuración simple para compartir carpetas en Windows instalando samba con CentOS

sambalinux

 

Una forma de disponer de un disco compartido para clientes Windows es usando el servidor de código libre samba. Vamos a ver como instalarlo y configurarlo de forma rápida en una CentOS, RHEL o Fedora.

 

Primero de todo deberemos instalar samba mediante yum:

# yum install samba -y

A continuación deberemos configurar el daemon mediante el fichero /etc/samba/smb.conf

[global]
workgroup = "workgroup_name"
server string = Samba Server
security = user
username map = /etc/samba/smbusers

name resolve order = hosts lmhosts

[documentos]
path = /home/ejemplo
force user = "ejemplo"
force group = "ejemplo"
read only = no
guest ok = no

Con este fichero de configuración definimos el recurso “documentos” como los datos que hay en /home/ejemplo, usando los permisos en el servidor del usuario “ejemplo” y el grupo “ejemplo”. A continuación deberemos definir los usuarios y contraseñas que podrán usar los usuarios para conectar a este recurso. Lo haremos con el comando smbpasswd:

# smbpasswd -a ejemplo
New SMB password:
Retype new SMB password:
Added user ejemplo.

Finalmente levantamos el servicio mediante el script de inicio del init.d:

/etc/init.d/smb start

Para que el servicio se levante una vez reiniciado el sistema deberemos usar la herramienta chkconfig:

# chkconfig --level 3 smb on